Oscyloskop DSO150 i problem z firmware

Przydatne narzędzia, porady dotyczące zakupu
Awatar użytkownika
Krzysztof
Administrator
Posty: 2860
Rejestracja: 19 kwie 2016, 14:03
Lokalizacja: Darłowo
Kontaktowanie:

Re: Oscyloskop DSO150 i problem z firmware

Postautor: Krzysztof » 10 gru 2018, 15:19

A postępowałeś zgodnie z instrukcją jaką podałem wyżej?

radeo
Posty: 3
Rejestracja: 29 lis 2018, 9:50
Kontaktowanie:

Re: Oscyloskop DSO150 i problem z firmware

Postautor: radeo » 12 gru 2018, 10:13

Tak, przeglądałem także tutorial na githubie, ale poległem w środowisku Arduino. Po prostu nie wiem jak załadować te źródła, a następnie je skompilować. Co więcej, kompilowałem je w Atollicu, ale po wgraniu programu do flasha oscyloskop nie wstaje. Po włączeniu działa tylko podświetlenie LCD :(

Awatar użytkownika
Krzysztof
Administrator
Posty: 2860
Rejestracja: 19 kwie 2016, 14:03
Lokalizacja: Darłowo
Kontaktowanie:

Re: Oscyloskop DSO150 i problem z firmware

Postautor: Krzysztof » 12 gru 2018, 17:00

Już bardziej łopatologicznie niż w instrukcji, którą wpisałem, nie potrafię wytłumaczyć. Czy użyłeś arduino w takiej samej wersji? Czy dograłeś obsługę dla STM32 (arduino zero)?

radeo
Posty: 3
Rejestracja: 29 lis 2018, 9:50
Kontaktowanie:

Re: Oscyloskop DSO150 i problem z firmware

Postautor: radeo » 13 gru 2018, 7:02

tak, postępowałem wg instrukcji powyżej, wersja Arduino taka sama, STM32 dograny. Na repozytorium jest zaznaczone, że te źródła były kompilowane pod Atolliciem, ja natomiast nie wiem jak je wrzucić do Arduino. Zatrzymałem się na p. 9.


Wróć do „Narzędziownia”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 3 gości